英文辅音字母是除AEIOU以外的字母。本题要求编写程序,统计给定字符串中大写辅音字母的个数。

输入格式:

输入在一行中给出一个不超过80个字符、并以回车结束的字符串。

输出格式:

输出在一行中给出字符串中大写辅音字母的个数。

输入样例:

HELLO World!

输出样例:

4
#include <stdio.h>
#include <string.h>
int main()
{
    char str[81] = "";
    int i,count = 0;
    gets(str);
    for(i=0;i<strlen(str);i++)
    {
        if(str[i]>='A' && str[i]<='Z'){
            switch(str[i])
            {
                case 'A':
                case 'E':
                case 'I':
                case 'O':
                case 'U':
                    break;
                default:
                    count++;
            }
        }
    }
    printf("%d\n",count);
    return 0;
}
Last modification:2021 年 03 月 27 日 16 : 37 : 31